instrument panel faults 406

Talk about the 406's electrical system, what wires do what, how to add extra functionality, etc.

Moderator: Moderators

Post Reply
duke
1.8 8v
Posts: 27
Joined: Fri Jan 27, 2017 10:21 pm

instrument panel faults 406

Post by duke » Fri Feb 15, 2019 4:15 pm

hi all i have an ancient pug 406 lx petrol 1.8 16v 1997 vintage and recall hearing talk somewhere maybe here of a fault that causes instrument panel intermitent faults ie speedo rev counter,fuel gauge etc not working but if you knock the cover it all comes to life for a while is it a case of resoldering or rewiring?i ssem to remember talk of dry solder and some kind of connector any advice gratefully recieved,peace :roll:

PeterN
3.0 24v
Posts: 1478
Joined: Sun Mar 04, 2012 7:04 pm
Location: Charmouth, Dorset

Re: instrument panel faults 406

Post by PeterN » Sat Feb 16, 2019 11:21 am

Sounds like a dry joint on the PCB. XMs use to suffer from this problem and it was usually the connectors on the edge of the board, they would develop a crack around the soldered joint. Examine the board carefully with a magnifying glass and you might find the problem.

Peter

duke
1.8 8v
Posts: 27
Joined: Fri Jan 27, 2017 10:21 pm

Re: instrument panel faults 406

Post by duke » Mon Mar 04, 2019 6:32 pm

PeterN wrote:
Sat Feb 16, 2019 11:21 am
Sounds like a dry joint on the PCB. XMs use to suffer from this problem and it was usually the connectors on the edge of the board, they would develop a crack around the soldered joint. Examine the board carefully with a magnifying glass and you might find the problem.

Peter
hi i dont suppose you or anyone knows where exactly the pcb is located and whats required to be removed to get to it?i guess most of the time but dont fancy taking the dashboard apart any more than needed!cheers :mrgreen:

PeterN
3.0 24v
Posts: 1478
Joined: Sun Mar 04, 2012 7:04 pm
Location: Charmouth, Dorset

Re: instrument panel faults 406

Post by PeterN » Tue Mar 05, 2019 11:25 am

Remove the instrument panel then the cover and its right in front of you, the faults are likely to be where the edge connectors plug in, check where the connections are soldered to the board.

Peter

archangel2
1.8 8v
Posts: 34
Joined: Sun Mar 24, 2019 11:02 pm
Location: NorthWest
Contact:

Re: instrument panel faults 406

Post by archangel2 » Mon Apr 29, 2019 9:27 pm

what size screws for instrument panel removal guys ? these are the things newbies need to know

Post Reply