Type C display issue

In Car Entertainment, Sat-Nav, Mobile Phones, Media players etc., whats hot, and whats not!

Moderator: Moderators

Post Reply
grasmere59
3.0 24v
Posts: 1421
Joined: Wed Jul 28, 2010 10:23 pm

Type C display issue

Post by grasmere59 » Sun Oct 27, 2019 4:38 pm

I managed to buy a mint Type C display for my 53 plate 406 exec estate,i fitted it and no missing lines or pixels!!........but i have now lost use of the CD multichanger and the remote volume control from the r/h column stalk,any ideas?? Put the old Type C back in and everything works fine again. :?
2011 "11" Mondeo TXS est 200ps in Grey
2003 "53" 110 hdi Executive Estate in Diablo Red
2001 "51" BMW 530i sport auto in Black
2012 "62" Yamaha XT1200 Super Tenere
1974 "M" Honda CB500/4
1994 "M" Kawasaki Zephyr 1100
1998 "S" Honda XRV 750 Africa Twin

GingerMagic
3.0 24v
Posts: 3201
Joined: Fri Apr 06, 2012 9:02 pm
Location: Bournemouth

Re: Type C display issue

Post by GingerMagic » Sun Oct 27, 2019 5:01 pm

It's a common issue.

The replacement type C is from a semi mux car and it is 'wired' whereas the newer fully mux are 'can bus' or something...

If you have access to PP2K then the MFD can be reconfigured to a full mux car, takes 5 mins.
1999 T4 family wagon
2005 Vauxhall Meriva
1998 406 V6 Coupe - Midlife crisis..!
PP2000 user, can help with faults / diagnostics in the Bournemouth area.

grasmere59
3.0 24v
Posts: 1421
Joined: Wed Jul 28, 2010 10:23 pm

Re: Type C display issue

Post by grasmere59 » Sun Oct 27, 2019 5:18 pm

Ah that makes sense,i'm not sure what year of 406 it came from as i never asked the seller,just got to find someone with pp2000 then or just live with it
2011 "11" Mondeo TXS est 200ps in Grey
2003 "53" 110 hdi Executive Estate in Diablo Red
2001 "51" BMW 530i sport auto in Black
2012 "62" Yamaha XT1200 Super Tenere
1974 "M" Honda CB500/4
1994 "M" Kawasaki Zephyr 1100
1998 "S" Honda XRV 750 Africa Twin

GingerMagic
3.0 24v
Posts: 3201
Joined: Fri Apr 06, 2012 9:02 pm
Location: Bournemouth

Re: Type C display issue

Post by GingerMagic » Sun Oct 27, 2019 5:49 pm

You could send it to someone with a full mux car and PP2K - they can reconfigure it then post it back to you.
Just a thought.
1999 T4 family wagon
2005 Vauxhall Meriva
1998 406 V6 Coupe - Midlife crisis..!
PP2000 user, can help with faults / diagnostics in the Bournemouth area.

grasmere59
3.0 24v
Posts: 1421
Joined: Wed Jul 28, 2010 10:23 pm

Re: Type C display issue

Post by grasmere59 » Sun Oct 27, 2019 7:21 pm

Few and far between now i fear.
2011 "11" Mondeo TXS est 200ps in Grey
2003 "53" 110 hdi Executive Estate in Diablo Red
2001 "51" BMW 530i sport auto in Black
2012 "62" Yamaha XT1200 Super Tenere
1974 "M" Honda CB500/4
1994 "M" Kawasaki Zephyr 1100
1998 "S" Honda XRV 750 Africa Twin

trem1
3.0 24v
Posts: 1818
Joined: Sat Dec 31, 2005 3:32 pm
Location: south shields,tyneside

Re: Type C display issue

Post by trem1 » Sun Oct 27, 2019 9:04 pm

grasmere59 wrote:Few and far between now i fear.
Not on the Facebook page, very busy page with over 12k members,still a very popular car

Sent from my K013 using Tapatalk



2004 Iron Grey 407se 136bhp......Written Off
2006 Moonstone blue 407 se 136 bhp.....Written off
2006 silver 407 SW..........replacement

Post Reply