No communication with engine ECU

Talk about the 406's electrical system, what wires do what, how to add extra functionality, etc.

Moderator: Moderators

Post Reply
FarmerPug
2.0 HDI 110
Posts: 9644
Joined: Tue Jun 01, 2010 5:42 pm
Location: The Countryside, Northern Ireland
Contact:

No communication with engine ECU

Post by FarmerPug » Sun Mar 11, 2018 1:18 am

I plugged PP2000 into someones 406 today as they are complaining about a lack of power (2.0 HDi 90), i know the 90s were never particularly potent but this one had no noticeable boost at all. PP2000 was unable to communicate with the engine ECU but seemed able to talk to all other modules.

User avatar
GingerMagic
3.0 24v
Posts: 2910
Joined: Fri Apr 06, 2012 9:02 pm
Location: Bournemouth

Re: No communication with engine ECU

Post by GingerMagic » Sun Mar 11, 2018 10:11 am

Ive had something similar before.
I had to pop the ECU out of its housing and look at the label on the side - then choose that ECU from the drop down menu when you look at the Engine ECU.

Siemens, Sagem etc..
1999 T4 family wagon, slow as a turd but the kids like it
2002 Citroen Xsara Picasso Hdi90 - Dirtied by the kids, Dented by the wife....
Sadly sold the 406, best cars I have ever owned
PP2000 user, can help with faults / diagnostics in the Bournemouth area.

PeterN
3.0 24v
Posts: 1355
Joined: Sun Mar 04, 2012 7:04 pm
Location: Charmouth, Dorset

Re: No communication with engine ECU

Post by PeterN » Sun Mar 11, 2018 10:12 am

Can't help with the PP2000 fault as neither of mine work but the fault with turbo boost is very often the vacuum supply. Mine had no power below 2000 rpm which I eventually found was due to a faulty vacuum pump but it can be caused by split rubber pipes that run along the back of the engine. Can you feel it start to boost at 2000 + revs? Mine is a 110 hp.

Peter

User avatar
GingerMagic
3.0 24v
Posts: 2910
Joined: Fri Apr 06, 2012 9:02 pm
Location: Bournemouth

Re: No communication with engine ECU

Post by GingerMagic » Sun Mar 11, 2018 10:41 am

The 90 has a mechanical wastegate, so no issues with vacuum pipes except for the EGR - which I guess could be jammed open and gummed up..
Possible MAF issue but PP2000 should give you the info.
1999 T4 family wagon, slow as a turd but the kids like it
2002 Citroen Xsara Picasso Hdi90 - Dirtied by the kids, Dented by the wife....
Sadly sold the 406, best cars I have ever owned
PP2000 user, can help with faults / diagnostics in the Bournemouth area.

Post Reply