Data has been deleted from BSI eeprom

Talk about the 406's electrical system, what wires do what, how to add extra functionality, etc.

Moderator: Moderators

Post Reply
keizer619
Newbie
Posts: 2
Joined: Mon Feb 05, 2018 11:00 am

Data has been deleted from BSI eeprom

Post by keizer619 » Mon Feb 05, 2018 11:06 am

I have a 1999 406 GTX 2.0 petrol car. There has been a water leak from the rear and driver side floor has been flooded with.
When i try to start it shows Key light in the dashboard.

Then my technician checked and said Data has been deleted from BSI eeprom. Worse case is replacing all three BSI, ECU and key :(
is there any dump file for the eeprom which i we could use to write to current eeprom?

User avatar
jonsowman
3.0 24v
Posts: 1706
Joined: Wed Sep 21, 2011 4:19 pm
Location: Surrey, UK (J9 M25)

Re: Data has been deleted from BSI eeprom

Post by jonsowman » Tue Feb 06, 2018 6:27 pm

I suspect the data is not gone, but the BSI is non-functional. EEPROMs are very hardy devices.

You can perhaps swap the EEPROM into a replacement BSI, see here: http://www.406oc.co.uk/viewtopic.php?f= ... 7&p=235612, although yours will be a bit different since it will be a semi-mux car and therefore have a Siemens BSI.
Image
2002 V6 SE Coupé (210bhp) - (Aegean Blue)
2002 D9 2.2 HDi Exec Estate - Samarkand Blue
PM me for PP2000 diagnostics around Surrey

User avatar
GingerMagic
3.0 24v
Posts: 2874
Joined: Fri Apr 06, 2012 9:02 pm
Location: Bournemouth

Re: Data has been deleted from BSI eeprom

Post by GingerMagic » Tue Feb 06, 2018 6:56 pm

When my friend David has similar issues with his car, he sorted all the faults by lifting the carpet, removing 2 gallons of water and removing the corroded connector and simply* soldering the wires together...

Initially the headlights were constantly on, the wipers and horn were not working, and the immobiliser was on.
All fixed now though.
1999 T4 family wagon, slow as a turd but the kids like it
2002 Citroen Xsara Picasso Hdi90 - Dirtied by the kids, Dented by the wife....
Sadly sold the 406, best cars I have ever owned
PP2000 user, can help with faults / diagnostics in the Bournemouth area.

keizer619
Newbie
Posts: 2
Joined: Mon Feb 05, 2018 11:00 am

Re: Data has been deleted from BSI eeprom

Post by keizer619 » Thu Feb 08, 2018 6:42 am

GingerMagic wrote:
Tue Feb 06, 2018 6:56 pm
When my friend David has similar issues with his car, he sorted all the faults by lifting the carpet, removing 2 gallons of water and removing the corroded connector and simply* soldering the wires together...

Initially the headlights were constantly on, the wipers and horn were not working, and the immobiliser was on.
All fixed now though.
Removed water but didn't solder wires and connectors , need to try that too.
jonsowman wrote:
Tue Feb 06, 2018 6:27 pm
I suspect the data is not gone, but the BSI is non-functional. EEPROMs are very hardy devices.

You can perhaps swap the EEPROM into a replacement BSI, see here: http://www.406oc.co.uk/viewtopic.php?f= ... 7&p=235612, although yours will be a bit different since it will be a semi-mux car and therefore have a Siemens BSI.
Yes i saw that thread too. Currently i am having a Siemens BSI, in my case chassi number and other related information is not shown when connecting through PP2000 Scanner. I thought its because data is removed from EEPROM, then i should try to swap into another BSI and see.

Post Reply