406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Shocks, springs, anything to do with the running gear

Moderator: Moderators

Post Reply
katgraffix
Newbie
Posts: 6
Joined: Tue Aug 09, 2016 5:25 pm

406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by katgraffix » Tue Aug 09, 2016 5:51 pm

I'm hoping one of you good people will be able to give me some pointers on my 406 coupe D9. I'm not new to 406's, this is my 5th now and was bought recently with no MOT and some faults to fix. Most of these have been the usual things but it also has a permanent ABS solenoid fault (rear left) showing in PP2000...obviously with the relevant ASR/ESP warning lights..see image one.
Fault Screen.jpg
(50.48 KiB) Downloaded 11 times
It has had 2 further ABS pumps fitted and then one ECU fitted to the ABS Pump so 3 ECUs and 2 Valve blocks#pumps in total, all showing the same fault after reading and clearing down so I don't believe the fault lies in the ABS Pump/Valve Block/ECU. I've added two further images that indicate "low voltage to pre-charge pump" and "the condition of solenoid valve = open". Should this be closed with the ignition on as the bottom of the page seems to indicate?
Test Screen 1.jpg
(75.64 KiB) Downloaded 11 times
Test Screen 2.jpg
(67.12 KiB) Downloaded 11 times
Anyone have any pointers on where to look...please don't suggest sensor rings or wiring back from them as this has been checked out. Thanks in advance!!

Jason

User avatar
Doggy
Mod with a 2.2 HDi, De-Fapped!
Posts: 10022
Joined: Mon Oct 13, 2008 11:49 pm
Location: Northants

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by Doggy » Tue Aug 09, 2016 11:56 pm

Hi Jason,

Never tried fault finding the ABS / ESP system as none of mine have had the latter, but when you have the fault message displayed, what suggestions does PP2k come up with when you press enter? (I'm trying to guess what information it uses to generate that fault message).

The stuff you've changed should obviously rule out the ecu and ABS pump / valve blocks, so what does that leave? Interconnections between them perhaps?
Looks like you have an intermediate 16-way connector, (IC11A), somewhere between the two rear ABS sensors and the control unit, no idea where. :?


I'll try to check my pre-charge pump voltage and 'solenoid valve condition when I get a chance.
(If anyone else gets there first, feel free to jump in).
2003 HDi 2.2 6-speed Exec Estate

katgraffix
Newbie
Posts: 6
Joined: Tue Aug 09, 2016 5:25 pm

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by katgraffix » Wed Aug 10, 2016 6:36 am

Thanks for the reply...it suggests checking the connections on cables 3 and 11 between 7800 and 7806. This, I understand, is the abs ecu and solenoid coils. The ecu has been changed three times so I can't see that really being correct.

User avatar
jonsowman
3.0 24v
Posts: 1707
Joined: Wed Sep 21, 2011 4:19 pm
Location: Surrey, UK (J9 M25)

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by jonsowman » Wed Aug 10, 2016 7:17 am

We had issues on one of the rear ABS sensors caused by water ingress in the driver's footwell.

There's several connectors under there, perhaps one of them is the one mentioned? Worth having a look anyway.
Image
2002 V6 SE Coupé (210bhp) - (Aegean Blue)
2002 D9 2.2 HDi Exec Estate - Samarkand Blue
PM me for PP2000 diagnostics around Surrey

katgraffix
Newbie
Posts: 6
Joined: Tue Aug 09, 2016 5:25 pm

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by katgraffix » Wed Aug 10, 2016 5:09 pm

Thanks for that...at least it's something else to check and rule out!! I'll have a look tomorrow.

User avatar
GingerMagic
3.0 24v
Posts: 3044
Joined: Fri Apr 06, 2012 9:02 pm
Location: Bournemouth

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by GingerMagic » Wed Aug 10, 2016 8:10 pm

Just to add, my friendly local Pug mechanic has seen many 406s with an issue with the nsr sensor...

He just runs a long wire from the sensor to the block, or wherever it's supposed to go, with no joins at all - works for him..
1999 T4 family wagon
2005 Vauxhall Meriva
1998 406 V6 Coupe - Midlife crisis..!
PP2000 user, can help with faults / diagnostics in the Bournemouth area.

katgraffix
Newbie
Posts: 6
Joined: Tue Aug 09, 2016 5:25 pm

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by katgraffix » Thu Aug 11, 2016 1:54 pm

No problems apparent under the carpet....

It has already had a new N/S/R abs sensor, also checked for damage over the heat shield where the problem usually is...and all sensors test OK with PP2000.

I believe where I need specific help and advice is with regard to the reported faults of "low voltage to pre-charge pump" and "the condition of solenoid valve relay = open" as these are relevant to the fault and I think the relay being open means that there is low voltage to the pre-charge pump. But, what/where is the relay and pre-charge pump???

Thanks, Jason

katgraffix
Newbie
Posts: 6
Joined: Tue Aug 09, 2016 5:25 pm

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by katgraffix » Mon Aug 29, 2016 12:59 pm

No-one able to help with this one??

User avatar
steve_earwig
Moderator
Posts: 18940
Joined: Thu Oct 04, 2007 6:09 pm
Location: Jastrebarsko, Croatia http://www.jastrebarsko.hr/lokacija/

Re: 406 Coupe 2.2HDi Permanent ABS Solenoid Fault

Post by steve_earwig » Mon Aug 29, 2016 1:18 pm

I've found a "primer pump" in the wiring diagram, I've no idea if this is the same thing. There is a relay too, but I've no idea how it all works :?

Jesus H. the ESP unit connector is shown as an 88-way, plenty of scope for problems there! :shock:
Attachments
relay.JPG
(67.5 KiB) Downloaded 5 times
primer pump.JPG
(58.76 KiB) Downloaded 5 times
Unskilled meddling sin©e 2007

2004 D9 2.0 HDi 110 Estate lhd VF38ERHZF81657352 - sold but being very well looked after.
1991 Yamaha TDM850 - fuel leaks galore!
2008 Toyota Recall4 2.0 VVTI ATM LHD JTMBH31V90D007261 - flimsy piece of crap.
1953 Matchless G3LS - It's alive!!

Post Reply