trip computer installation

Knowledge Base Articles

Moderator: Moderators

Locked
User avatar
DaiRees
Site Admin
Posts: 5350
Joined: Sat Aug 06, 2005 8:24 am
Location: Merthyr Tydfil, South Wales (God's Country!)

Re: trip computer installation

Post by DaiRees » Wed May 05, 2010 8:12 am

Good Man!! Thanks for letting us know :cheesy:
Image
Playtime_Fontayne wrote:"Dai Rees Supplier of Fine Automobilia. Established 2007"

maxxymilian
2.0 16v
Posts: 152
Joined: Mon Dec 21, 2009 8:55 am
Location: bulgaria

Re: trip computer installation

Post by maxxymilian » Wed May 05, 2010 10:05 am

Here is the sagem wiring diagram and Marelli ecu connector

Image

Image

User avatar
mjb
Site Admin
Posts: 7955
Joined: Wed May 31, 2006 9:06 pm
Location: Stoke

Re: trip computer installation

Post by mjb » Wed May 05, 2010 10:35 am

Is it still beige? :lol:

Have you looked to see if the pin's available on any of the diesel ECUs?
<steve_earwig> I think this forum is more about keeping our cars going with minimal outlay than giving our cars more reason to go bang

teamster1975
Site Admin & Mad Biker!
Posts: 6270
Joined: Sun Oct 28, 2007 9:07 pm
Location: Woking, Surrey

Re: trip computer installation

Post by teamster1975 » Wed May 05, 2010 11:51 am

Top man, thanks for sharing Maxxy! :D
1996 406 1.8LX Got a bad case of hydro lock!
1996 406 Executive 2.0 Turbo XU10J2TE No longer hangin' on in there :(
1997 Honda CB500V
2003 Volvo V40 1.8 GDi SE killed by a nutter in a beemer 5 series
2008 Mondeo 2.0 TDCi Titanium X

"Always look on the bright side of life, dedo, dedo dedodedo"

User avatar
plod
3.0 24v
Posts: 2725
Joined: Sun Jun 29, 2008 9:42 pm
Location: Hinckley

Re: trip computer installation

Post by plod » Wed May 05, 2010 8:36 pm

mjb wrote:Have you looked to see if the pin's available on any of the diesel ECUs?

Oh, I do hope so :D
1999 D8.5 HDi GLX - Sold :(

2007 Mondingo Zetec - I seek forgiveness :( Bring back my 406

djvaliro
Newbie
Posts: 6
Joined: Sun May 30, 2010 10:56 pm

Re: trip computer installation

Post by djvaliro » Sun May 30, 2010 11:22 pm

hi guys .. i have a 2L turbo brgx xu10j2te or xu10j2cte very confusing. Is this mod possible for my 406 pug .. i have Motronic MP 3.2 ECU ???.

I already started the mod a few days back .. just from curiosity coz i bought the service manual from france and now i see that some of you have already done' it.

From here i d'ont have the schematics .. or they are fuzzy/incomplete , ca you guys point me in the right direction (if it's possible for this model - i bet it is, maybe i just don't have all the info). I've found info on french websites but incomplete.
Thanx in advance.

Update :
So where i am now is :
- found the 1368 lead on a brown connector under the wheel - not connected just stops there. - on my ECU is on pin 32 - who has autodata can see all models
- added 3 extra wires to the display and another 2 for the whipers button / TC
- connected 1368 to pin 12 - B15 on display. - be careful on display are 2 sets of connectors A15 and B15
- pin 2 - B15 -->> ground -12v.2
- found pin 5 - B15 --->> ground -12v - on display its trip computer button that changes menu .
- pin 6 - B15 --->> dashboard pin 15 yellow26
- pin 10 B15 --->> dashboard pin 21yellow26
- pin 12 B15 --->> 1368 ECU pin 4 in my case 32, still don't know where to connect 'it from brown connector or directly on the ECU.


It became clear now after reading all posts and seen schematics from mjb and maxxymilian who posted the pics, these things reassured me i'm right. THANX guys.

Ok .. i did all the wiring, when i push the button it works i can change menus - l/1oo - km/h etc, but it does not say the amount of gas in the tank ..!!! it blinks if i disconnect wire 4315 from dashboard brown wire the one cut like in the photos of maxxymilian - Is this normal ? .. i think i forgot something.

User avatar
mjb
Site Admin
Posts: 7955
Joined: Wed May 31, 2006 9:06 pm
Location: Stoke

Re: trip computer installation

Post by mjb » Tue Jun 01, 2010 12:05 pm

See my posts on page 4 of this thread with the wiring diagrams and wires 720+4315 - the fuel gauge wire needs to go *through* the trip computer on the way to the instrument cluster! If memory serves I cut mine just before the instrument cluster plug
<steve_earwig> I think this forum is more about keeping our cars going with minimal outlay than giving our cars more reason to go bang

djvaliro
Newbie
Posts: 6
Joined: Sun May 30, 2010 10:56 pm

Re: trip computer installation

Post by djvaliro » Tue Jun 01, 2010 9:19 pm

Thanx mjb for the quick response, i did everything like there, cut the wire i did everything like in the pictures posted by maxxymilian - http://img85.imageshack.us/gal.php?g=dsc05983r.jpg except the 1368 wire wich i soldered on pin pin 12 B15 (wich is not displayed in those pics).. by the way is this wrong ! .. were to put this wire ?.-

Everything is working - only the petrol is not reported. Rechecked, everything is connected as in the schematics.

torture
Newbie
Posts: 2
Joined: Wed Jun 02, 2010 2:47 pm

Re: trip computer installation

Post by torture » Wed Jun 02, 2010 3:03 pm

You have to drive about half a mile and it will start to show you the amount of petrol left in the tank did you try that?Oh and can you please post a pic of where exactly 1368 i located because i couldn't find it.I got everything to work except MPG and average MPG.

djvaliro
Newbie
Posts: 6
Joined: Sun May 30, 2010 10:56 pm

Re: trip computer installation

Post by djvaliro » Wed Jun 02, 2010 5:36 pm

- found the 1368 lead on a brown connector under the wheel - not connected just stops there. - on my ECU is on pin 32 - who has autodata can see all models
i d'ont recall the number of the pin .. but iven if i tell you the number of the pin i cannot gurantee it s the same, the color is violet though. But i can tell you how to make sure it's the right one.
Take a long wire (to be able to get inside the car), a multimeter set to continuity ... put one end of the wire on pin 32 (or the number mentionned in the schematic for your model) in the ECM connector (black), the other end connect'it to one of the multimeters pin and with the other pin of the multimeter check all the pins in the brown round connector under the weel. If still nothing check te blue one.
Here is something to help you out .. some pics.http://djvaliro.com/pug/index.php?dir=a ... ipcomp.pdf

Update:

I verified today the pin nuber is 21 if you look close might see the number. As for the fuel quantity .. i drove a few miles and still nothing. Maibe coz i ran out of fuel .. maibe when i'll do a full tank tomorow it will show me somenthing.
Anyway thanx to all of you guys who contributed for this also to 406oc.co.uk :roll: , :arrow: - for the info schematics and documentation .. this problem was buggin'me for some time, until i did a search in english :wink: .
Last edited by djvaliro on Thu Jun 03, 2010 3:47 pm, edited 1 time in total.

torture
Newbie
Posts: 2
Joined: Wed Jun 02, 2010 2:47 pm

Re: trip computer installation

Post by torture » Thu Jun 03, 2010 2:48 pm

Thanx for the tips man but i think that i just don't have that cursed 1368.Checked all the wires in the brown and blue connectors and still nothing.

User avatar
plod
3.0 24v
Posts: 2725
Joined: Sun Jun 29, 2008 9:42 pm
Location: Hinckley

Re: trip computer installation

Post by plod » Thu Jun 03, 2010 8:15 pm

Think i'm going to be doing some investigating on my loom as I have seen info about the trip computer working on some d9 hdi's
1999 D8.5 HDi GLX - Sold :(

2007 Mondingo Zetec - I seek forgiveness :( Bring back my 406

djvaliro
Newbie
Posts: 6
Joined: Sun May 30, 2010 10:56 pm

Re: trip computer installation

Post by djvaliro » Thu Jun 03, 2010 8:43 pm

to plod .. if your pug has bsi it's much simpler than our old D8 .. wich don't have.
Just have to put two wires
1368 from ECU to BSI pin9
and another one from bsi pin 1 to ground wich is the button . The connector on the bsi should be brown 12 wires / as it states in here :arrowd: .

After you have done the wiring put a diagnostic interface on it and activate the function OBD present in PPS2000 Lexia only.
I don't gurantee for this info but seems that some french ppl did'it. So you could at least verify this. Compare schematics like i did. In my case it worked no bsi. Cheers.
Image

maxxymilian
2.0 16v
Posts: 152
Joined: Mon Dec 21, 2009 8:55 am
Location: bulgaria

Re: trip computer installation

Post by maxxymilian » Fri Jan 14, 2011 9:48 am

New info guys:

1368 wire is present in 1.6 too:

1.6 BFZ Magneti Marelli 8P - pin 7
1.8 8v LFX Sagem SL96 - pin 5
1.8 16v LFY Magneti Marelli 1AP20 - pin 5
1.8 16v LFY Sagem SL96 - pin 5
1.8 16v LFY Bosch MP 5.1.1 - pin 4
2.0 16v RFV ECU Bosch MP 5.2 - pin 4
2x406 D8 beauties 1.8 16V 96/98 LPG Image

User avatar
highlander
PowerFlow Shill
Posts: 3524
Joined: Sun Nov 09, 2008 6:03 pm
Location: Aberdeen

Re: trip computer installation

Post by highlander » Fri Jan 14, 2011 10:20 am

Yes, but can the 1.6 engine actually move the 406 far enough to require a trip computer? :cheesy:

Has anyone here ever actually laid eyes on a 1.6?
Image
2002 (D9) Peugeot 406 Coupe SE, 2.2 litre Petrol. Scarlet Red/Rouge Ecarlate/Rosso Scarlatto. Black Leather interior.
You put your foot down and the car just goes "GRRRRRAAAWWWRRRR"

Locked