Idle problem 2.0 8v turbo- help needed

Discuss, ask, or get help with engine and mechanical queries in here.

Moderator: Moderators

Post Reply
PUGNUTXS
Newbie
Posts: 8
Joined: Sun Jul 06, 2014 3:55 pm

Idle problem 2.0 8v turbo- help needed

Post by PUGNUTXS » Tue Oct 14, 2014 6:26 pm

I have finally got my project running but from when I started it up the revs slowly went up to 4000 rpm and stayed there. I disconnected the throttle position sensor and the revs dropped to 1500 rpm. I changed the throttle pos sensor but did not cure the fault. The car has no exhaust on it so no lambda probe fitted

While it was running I disconnected the yellow connector connected on the left hand of the throttle housing but that did nothing. It still sat at 1500 rpm with throttle pos sensor disconnected

Next I am going to clean out the idle air control valve and see what happens

I am hoping it's not the ecu otherwise that's my project over before I have had chance to finish it

Any help is greatly appreciated

madmadmax
2.0 Turbo
Posts: 484
Joined: Sun Jan 01, 2012 6:49 pm
Location: sheffield, south yourkshire

Re: Idle problem 2.0 8v turbo- help needed

Post by madmadmax » Tue Oct 14, 2014 8:07 pm

if its the ecu then you can get a diy set up megasquirt that will do the job or the other choes is emerald all you have to do is set up the wireing

http://www.megamanual.com/MSFAQ.htm


http://www.emeraldm3d.com/

PUGNUTXS
Newbie
Posts: 8
Joined: Sun Jul 06, 2014 3:55 pm

Re: Idle problem 2.0 8v turbo- help needed

Post by PUGNUTXS » Thu Dec 04, 2014 5:31 pm

I think the IACV is faulty but at £112 that one is going to have to wait. Another person on the 306 forum has said that the TPS and the IACV need calibrating????, Such a shame as the project was going so well. :cry:

Another person said it could be an air leak??

If it is the ECU however i am looking at a vems set up from DP Engineering.

Again all advice is appreciated.

D4B
2.0 16v
Posts: 172
Joined: Sat Mar 15, 2014 9:38 pm
Location: Hampshire

Re: Idle problem 2.0 8v turbo- help needed

Post by D4B » Thu Dec 04, 2014 7:54 pm

Didn't I read somewhere that you can recalibrate the TPS with the ignition on but engine not started,
something involving pressing the throttle pedal to the floor? or perhaps Gingermagic told me....

If not I am talking utter B@##@(£s
My other Peugeot was a D4B

PUGNUTXS
Newbie
Posts: 8
Joined: Sun Jul 06, 2014 3:55 pm

Re: Idle problem 2.0 8v turbo- help needed

Post by PUGNUTXS » Tue May 05, 2015 7:18 pm

Ok it's been a while since I posted but I cured the fault, there was a feed wire that goes from the relay block to the iacv that was corroded.

Since then the engine will not idle properly, it hunts like mad. Lost on this one as it has a brand new iacv

Anybody got any clues to cure it?

PUGNUTXS
Newbie
Posts: 8
Joined: Sun Jul 06, 2014 3:55 pm

Re: Idle problem 2.0 8v turbo- help needed

Post by PUGNUTXS » Wed Sep 02, 2015 5:36 pm

HI All

I still have this erratic idle issue, the engine idles up and down between 950-1100 rpm, i have a brand new iacv fitted, the Throttle position sensor appears ok, disconnecting it makes no difference to the idle either.

On a better note, the car is now finished and on the road, flew through the MOT with no advisories, i thought with the idle issue it would fail the emissions, but good as gold.

Just need to solve the issue with the idle, can anybody offer any advice?

User avatar
fattail95
2.0 Turbo
Posts: 397
Joined: Wed Jun 24, 2009 6:35 pm

Re: Idle problem 2.0 8v turbo- help needed

Post by fattail95 » Wed Sep 02, 2015 10:17 pm

I personally have absolutely no experience with petrol 406's, but on my old classic Mini (it was an MPi with fuel injection, not a carb'd one) sometimes the IACV's stepper motor would need resetting/recalibrating thorugh a special code reader if it was cleaned/replaced, is there an option in PP2000 to do this on yours?
2001/Y Peugeot 406 2.0 HDi Saloon
150hp/330nm Powerflow stainless exhaust Kevlar clutch Cat delete EGR & Doser delete Leather interior Windows tinted Cruise control 5 dial cluster Yatour bluetooth Starfish alloys Twin rear fogs

PUGNUTXS
Newbie
Posts: 8
Joined: Sun Jul 06, 2014 3:55 pm

Re: Idle problem 2.0 8v turbo- help needed

Post by PUGNUTXS » Wed Oct 25, 2017 2:05 pm

Hi all

Can anybody help at all?..... I need the Technical Data or a repair manual so that i can do an engine rebuild on my XU10J2TE unit. I have tried everywhere and even at my local Peugeot dealer i got a blank look off the service dept.

Any help is really appreciated

Post Reply